Question

Wordpress maximum upload file size not updating

I have updated my php.ini file to have the values below. I have restarted the server.

upload_max_filesize 64M post_max_size 128M memory_limit 256M max_execution_time 300 max_input_time 300

/etc/ini.d/apache2 restart

BUT my WordPress upload size is still 8mb. What am I missing? Please include command lines to suggestions.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi,

I believe that your php.ini is not accurate, try to use the following:

 max_execution_time = 300 
 max_input_time = 300 
 memory_limit = 256M 
 upload_max_filesize = 64M 
 post_max_size = 128M

Also, you can use this website to generate your php.ini file

Felipe

Hello,

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps! Regards, Alex

Hi

Thanks for this Solution,

I was facing the same issue with my blog TechiBhai

But Now, I have fixed it, by following your instructions