Question

Wordpress Memory Limit Shows 40MB and cant Raise

  • Posted February 23, 2015

Hello i tried everything including

https://wordpress.org/support/topic/php-memory-limit-not-updated this link 4 method

i cant raise wp memory limit 128MB it always says 40MB after all edit i restart server i change cp-config.php

help please i use digital ocean wordpress 14.04 application.

wanna raise wp memory limit.

also i check php.ini file it shows 512M

Thanks.

Subscribe
Share

my solution was to add define( ‘WP_MEMORY_LIMIT’, ‘256M’ ); before require_once(ABSPATH . ‘wp-settings.php’);

the last one works fine. Thanks magician11

40Mb is being reported in WordPress… and I also see 512M in the above mentioned php.ini file

Which php.ini file did you check? The DigitalOcean WordPress one-click application uses Apache for its webserver. The PHP configuration can be found in /etc/php5/apache2/php.ini It will default to 512M

Where is 40MB being reported, and how are you determining whether the memory limit is not being respected?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I think maybe what you are after (in your php ini) is:

upload_max_filesize

change that to 128M (not MB) and also change:

 post_max_size

restart apache and see if that works.

Hello, all

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of memory_limit you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

memory_limit = 256M

You also need to restart your web server in order the changes to take effect.

Hope that this helps! Regards, Alex

No, you don’t have to add any extra code. The reason it not showing because you defined the define( ‘WP_MEMORY_LIMIT’, ‘128M’ ); at the wrong place in the wp-config file. Just move this code at the very beginning under <?php

I have the same problem solved from here: https://www.how2shout.com/how-to/wordpress-memory-limit-shows-40mb-even-after-raising-php-memory-limit.html

This comment has been deleted