Question

WordPress Multisite is unable to upload media files because it does not have the necessary permissions.

WordPress 3.5 changes where media files are uploaded from blogs.dir to wp-content/uploads/sites/{site_id}. I have configured Multisite to use subdomains and the only way I have been able to allow WordPress to upload files (images) is to manually create the necessary folder structure and then to give 777 permissions.

$ chmod 777 /var/www/wp-content/uploads/sites/2 $ chmod 777 /var/www/wp-content/uploads/sites/3 etc.

This seems as though PHP does not have permissions to create/write files on my droplet. I’d obviously prefer my permissions to be 755. Any thoughts?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@a.single.drop: What’s the output of these commands? <br><ol><li>ps wwaux | grep apache</li><li>stat /path/to/wp-content</li></ol>

I’m still very new to this and ran across this same problem. I set up LAMP on my Ubuntu 12.10 server using the tutorial, virtual hosting with Apache2 again using the tutorial and then installed Wordpess, pointing it towards the Apache2 virtual host that I had setup. I ran into this same bug, and tried to use what you all suggested without any success. <br> <br>Initially, it told me I didn’t have the permissions to do that, so I tried to log in again into my root account (which I didn’t disable) and it did not give me the error message, but also did not fix my problem. I tried restarting the servers, but the problem has persisted. <br> <br>Anything else I can try? or any particular Apache2 config file I should look at to see if my changes are doing anything? Thanks in advance!

Try adding the user that owns /var/www/wp-content/uploads to the www-data group and chmod uploads to 775: <br> <br>usermod -a -G www-data youruser <br>chmod 775 /var/www/wp-content/uploads