WordPress on nginx/ubuntu & namecheap (comodo) ssl

March 15, 2014 2.5k views
Hello, When i try to visit my site using https://site.com it downloads a file and doesnt load the page. I am trying to setup the SSL to work on every page not only checkout pages.
3 Answers

Could you please post your nginx config file here so I can examine it and see what the issue is.
Have you correctly included the mime types in your configuration?

http {
include conf/mime.types;
Make sure you copy the location ~* \.php$ section from your regular virtualhost to your SSL-enabled virtualhost.
Have another answer? Share your knowledge.