After I create a droplet with the WordPress one-click install, I can not access the WordPress setup. The IP address for the droplet returns a continuously loading page and eventually returns ERRCONNECTIONTIMED_OUT.

What to do about this?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Just tried 2 times – doesn’t work. The domain is up for a few minutes and then unreachable!

Hello,

I believe that you need to first SSH to the Droplet and complete the Wordpress setup process through there. This would start your Apache web server and your Wordpress website will be available after that via your browser.

Let me know if you have any questions!
Regards,
Bobby

  • Hi Bobby. Yes I have run the whole setup process from within the console every time I’ve tried it. I’ve followed tutorial videos on YouTube and they seem to have no problem just punching in the IP of the droplet and accessing WordPress as soon as they change the UNIX password. But this is not the case for me.

    I have just tried it again with the same result.

    Is it safe to share the IP of the droplet here?

    • Hello,

      It sounds like that this is a firewall issue. To narrow it down, can you do the following:

      • SSH to your Droplet and check if Apache is listening correctly on port 80:
      sudo netstat -plant | grep 80
      
      • Try making a curl request from the Droplet itself to see if it can get to port 80:
      curl droplet_ip_address
      
      • Check the UFW status:
      sudo ufw status
      
      • Another thing that you could try doing is double-checking that your Droplet is not behind a DigitalOcean firewall

      Regards,
      Bobby

Hello, @hsvejsan88

Could you please let me know if the installation process went completely fine without any issues, e.g no error message were loaded and etc? Keep in mind that the installation process needs to be completed via ssh so you need to access your droplet.

Have you tried checking if the virtual host has been created after the installation completed?

You can double check this tutorial in order to see how the virtual host setup should be: https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

Also have you made some firewall related changes on the droplet?

Let me know how it goes.

Regards,
Alex

by Lisa Tagliaferri
This tutorial will guide you through setting up multiple domains and websites using Apache virtual hosts on an Ubuntu 18.04 server. During this process, you’ll learn how to serve different content to different visitors depending on which domains they are requesting.
  • Hi Alex. As I mentioned in my reply to Bobby above I have finished the installation every time via ssh. It has returned “Completing the installation of WordPress. Installed successfully” every time. No apparent error messages as far as I have noticed.

    I do have a firewall setup for my other droplet and I double-checked now and the only droplet that is listed under that firewall is my centos droplet and not this one.

    I’m unsure as to how exactly verify that apache was setup correctly. But I do have the /var/www/html folder full of WordPress files.

    /etc/apache2/sites-available/000-default.conf
    I also have these files.

Submit an Answer