Wordpress One-Click site won't work after enabling LetsEncrypt

March 2, 2019 296 views
Let's Encrypt WordPress

I did the Wordpress One-Click Install and afterwards, I went to my IP Address and it let me go through the Wordpress installation and the site worked perfectly fine. However, after enabling Let’s Encrypt via SSH, my site no longer loads. It just hangs. I have my domains forwarding properly with A records (@ and www) so I’m not sure what the issue is. Here’s a list to the ports (below). Any help please!

I also tried destroying my droplet and starting a new one and sure enough, same issue.

sudo lsof -iTCP -sTCP:LISTEN -P
systemd-r 580 systemd-resolve 13u IPv4 15246 0t0 TCP localhost:53 (LISTEN)
mysqld 1023 mysql 27u IPv4 19907 0t0 TCP localhost:3306 (LISTEN)
sshd 1588 root 3u IPv4 23159 0t0 TCP *:22 (LISTEN)
sshd 1588 root 4u IPv6 23170 0t0 TCP *:22 (LISTEN)
master 1772 root 13u IPv4 23636 0t0 TCP localhost:25 (LISTEN)
master 1772 root 14u IPv6 23637 0t0 TCP ip6-localhost:25 (LISTEN)
apache2 1974 root 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 1974 root 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2118 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2118 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2119 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2119 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2120 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2120 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2121 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2121 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2122 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2122 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2203 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2203 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)
apache2 2205 www-data 4u IPv6 25063 0t0 TCP *:80 (LISTEN)
apache2 2205 www-data 6u IPv6 26074 0t0 TCP *:443 (LISTEN)

1 Answer

The strange thing is, the site worked fine on cellular data (LTE) on my mobile phone but would not load on my wifi so initially I thought it was an ISP cache but that wasn’t it. Let’s Encrypt was not the issue but it was my wifi DNS settings which was caching the wrong name server or domain ip address. I changed my wifi connection DNS settings from “automatic” to Google’s free public DNS: 8.8.8.8 and 8.8.4.4 and now page loads fine. Only other issue I had after install (that’s not covered in the one-click documentation) was that stylesheets were loading under my IP address so the page was broken but once I went into the dashboard at IP-address/wp-admin and changed the Settings > General of wordpress URL and site URL to my domain name (not IP address) that fixed this issue. Just writing here in case it helps someone in the future.

Have another answer? Share your knowledge.