Question

Wordpress permissions

Hi, on wordpress, I get this error when updating plugins, it seems to be related to Server hosting permissions

Update failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions. /home/admin/web/activelifeapp.com/public_html/wp-content/languages/fr_FR.po, /home/admin/web/activelifeapp.com/public_html/wp-content/languages/fr_FR.mo, /home/admin/web/activelifeapp.com/public_html/wp-content/languages/admin-fr_FR.po, /home/admin/web/activelifeapp.com/public_html/wp-content/languages/admin-fr_FR.mo


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

Usually, you’ll have 750 permissions for your directories and 640 for the files. However, in some cases, this won’t be sufficient.

Running 755 for directories and 644 for files is also an option, as per Bobby’s suggestions.

  1. sudo find /var/www/wordpress/ -type d -exec chmod 750 {} \;
  2. sudo find /var/www/wordpress/ -type f -exec chmod 640 {} \;

These permissions should get you working effectively with WordPress, but note that some plugins and procedures may require additional tweaks.

Regards

Hi there,

You could try setting the permissions of the languages directory to 755 as follows:

chmod 755  /home/admin/web/activelifeapp.com/public_html/wp-content/languages/

If this is still not working check the ownership of that directory with :

ls -lah  /home/admin/web/activelifeapp.com/public_html/wp-content/

Feel free to share the output here.

Best,

Bobby