Question

Wordpress Registration Email Not Sending

Posted February 17, 2015 15.7k views

Hello everyone.

I opened registration to visitors in one of my wordpress websites and registration is not working properly.

I just tried “Lost Password?” function and it gave me this error:

“The e-mail could not be sent.
Possible reason: your host may have disabled the mail() function.”

My server is Ubuntu 12.04; LEMP - running on nginx.

Is there a way to fix this problem without messing up?

I appreciate your help. Thanks,

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
6 answers

if you install sendmail, as ryan mentioned, be sure to do:

sudo apt-get install sendmail

and then configure sendmail(just choose the defaults)

sudo sendmailconfig

reboot

You will need to install an MTA (Mail Transfer Agent) on your droplet in order to route mail for PHP. You can do this simply by installing postfix or sendmail on your droplet.

Problem solved. Thanks.

Problem not solved!

I tested this option and the result on this page: /wp-login.php?action=lostpassword is:

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Looking in the config log the following info appears:

2015/06/26 10:44:35 [error] 3595#0: *8 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 92.247.239.168, server: dekoration.haus, request: "POST /wp-login.php?action=lostpassword HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "46.101.255.114", referrer: "http://46.101.255.114/wp-login.php?action=lostpassword"


2015/06/26 10:45:21 [error] 3595#0: *3 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 92.247.239.168, server: dekoration.haus, request: "POST /wp-login.php?action=lostpassword HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "46.101.255.114", referrer: "http://46.101.255.114/wp-login.php?action=lostpassword"

UPDATE: This tread helped me find out how to deal with this error problem:
https://www.digitalocean.com/community/questions/sendmail-is-slow-to-send-mail

Submit an Answer