georgie
By:
georgie

Wordpress says it is installed, but still showing default page at IP address

October 31, 2016 98 views
WordPress One-Click Install Apps

Hi,

I am trying to set up my first droplet (a one click Wordpress install).

I have set up the address, and am then able to log in via the Terminal on my Mac. I get a message telling me that Wordpress has been successfully installed and should be able to be viewed from the IP address.

It then asks me to reset the root password.

When I do this, it kicks me out.

I then tried to access the wordpress site using the IP address but it still says "Please log into your droplet via SSH to enable your WordPress installation."

So I tried logging back into it via the Terminal, and the exact same thing happens - I get a successful message, kicked out after entering a password (Connection to XXX.XXX.XXX.XXX closed) but no wordpress install.

What am I doing wrong?

1 Answer

When using password authentication instead of an SSH key you will be prompted to change your password on your first log in. This can cause some confusion, this is the process:

1.) Provide password to log in.
2.) Type current password again to confirm
3.) Enter a new password
4.) confirm the new password.

If you try and type your new password at step 2 instead of providing the one that was emailed to you the session will be closed. I believe that the process that activates the WordPress installation occurs after the password reset process which is why it is not occurring. I will check with our images team to see if we can clarify the message shown there.

Have another answer? Share your knowledge.