JJD
By:
JJD

WordPress set up with Easy Engine now unable to connect to my site...

May 22, 2017 593 views
Apache WordPress Ubuntu 16.04

Hey guys thanks in advance I have spent hours and hours trying to fix my problem but lets get straight into this.

First of all this is how I have set-up my site / droplet:
-Created a droplet / edited Domain / pointed names servers
-Completed initial set-up for server (sudo user etc)
-Ran easy engine
-edited firewall settings to allow traffic

This brings me to today where I can still not access my site I get the following message when trying to access it through my browser "servers dns address cannot be found". Also I can not access my word press dashboard.

I have tried numerous fixes found online which have worked for others but not one has worked for myself. Are there any sort of logs or screen shots to assist you in helping me resolve my issue?

Additional INFO:
I have had my site up and domain name working in the past, but decided to delete the old droplet and create a new one.
I have created multiple droplets whilst trying to fix my issue, I have also tried install word press manually (not through easy engine).

1 comment
2 Answers

@JJD

When you setup your domain, did you use DigitalOcean's name servers? If so, was the domain also setup through the dashboard under Networking? If you've not added your domain yet, and set it to point to the Droplet IP, that may very well be the issue.

If you're able to provide the domain name, we can check for any potential issues in the zone file.

  • thanks for the reply Yes to tall of the above, the domain I am trying to access is simplytldr.com

@JJD

The issue I'm seeing is that when I access simplytldr.com, I'm redirected to the domain with the www instantly.

Normally, that's not an issue itself, but what is an issue is that you don't have a valid CNAME for www, so when I'm redirected, www.simplytldr.com results in failed resolution.

So you would need to add a CNAME to your DNS that points www to simplytldr.com, like so:

CNAME          www          simplytldr.com

From the DigitalOcean Dashboard => Networking => simplytldr.com

Hostname          =>          www
Is An Alias of    =>          simplytldr.com

You can leave TTL at its default setting.

Now, as long as NGINX is setup to respond to both variations, that should resolve the issue. You'd want to check server_name to make sure it looks something like:

server_name simplytldr.com www.simplytldr.com;

EasyEngine may do a slightly different setup, but it looks like it's redirecting all traffic on the main domain (simplytldr.com) to www.simplytldr.com and since that entry is missing, it won't resolve.

  • I don't know why but I have had a c-name row in the past and it never made a difference but this time it worked!
    Thank you so much!

Have another answer? Share your knowledge.