WordPress set up with Easy Engine now unable to connect to my site...

Hey guys thanks in advance I have spent hours and hours trying to fix my problem but lets get straight into this.

First of all this is how I have set-up my site / droplet: -Created a droplet / edited Domain / pointed names servers -Completed initial set-up for server (sudo user etc) -Ran easy engine -edited firewall settings to allow traffic

This brings me to today where I can still not access my site I get the following message when trying to access it through my browser “servers dns address cannot be found”. Also I can not access my word press dashboard.

I have tried numerous fixes found online which have worked for others but not one has worked for myself. Are there any sort of logs or screen shots to assist you in helping me resolve my issue?

Additional INFO: I have had my site up and domain name working in the past, but decided to delete the old droplet and create a new one. I have created multiple droplets whilst trying to fix my issue, I have also tried install word press manually (not through easy engine).

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.


The issue I’m seeing is that when I access, I’m redirected to the domain with the www instantly.

Normally, that’s not an issue itself, but what is an issue is that you don’t have a valid CNAME for www, so when I’m redirected, results in failed resolution.

So you would need to add a CNAME to your DNS that points www to, like so:

CNAME          www

From the DigitalOcean Dashboard => Networking =>

Hostname          =>          www
Is An Alias of    =>

You can leave TTL at its default setting.

Now, as long as NGINX is setup to respond to both variations, that should resolve the issue. You’d want to check server_name to make sure it looks something like:


EasyEngine may do a slightly different setup, but it looks like it’s redirecting all traffic on the main domain ( to and since that entry is missing, it won’t resolve.


When you setup your domain, did you use DigitalOcean’s name servers? If so, was the domain also setup through the dashboard under Networking? If you’ve not added your domain yet, and set it to point to the Droplet IP, that may very well be the issue.

If you’re able to provide the domain name, we can check for any potential issues in the zone file.