Question

WordPress takes 1 minute to create a new user account

  • Posted on December 12, 2013
  • lildave78Asked by lildave78

Hi there,

I’ve been trying to work out why my site is taking so long to create a user. Initially I thought it may be a problem with my code, but it’s actually a server issue.

When I try to create a new user (any user type) on WordPress, it takes about 1 minute and 2 seconds to create it. It seems like it has a 60 second timeout, and then creates the account in ~1-2 seconds.

Does anyone know if there is something I can change to stop this from happening?

Thanks in advance for you help!

Regards, David


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey guys, <br> <br>Thanks for your replies. I managed to get this working. Here are the details to overcome this if anyone else experiences a similar issue. In short, the issue seemed to be when I choose to have WordPress pre-installed on 12.10. <br> <br>- I was experiencing this issue on the 2GB / 2 CPUS droplet with WordPress pre-installed on Ubuntu 12.10 <br>- I created a new 2GB / 2 CPUS droplet but didn’t choose to pre-install WordPress on Ubuntu 12.10, but rather use LAMP on Ubuntu 12.04 <br>- I then used this guide to install WordPress: https://www.digitalocean.com/community/articles/how-to-install-wordpress-on-ubuntu-12-04 . Make sure you follow some of the instructions in the comments section as they are necessary to getting everything working properly. <br>- WordPress now works perfectly. <br> <br>Hope this helps! <br> <br>Cheers, <br>David

Are you using Apache on a 512 MB droplet?

What webserver are you using? Is MySQL installed on the same droplet?