Wordpress Theme Won't Install - Already checked other Questions...

December 4, 2015 1.5k views
WordPress PHP


I tried to install a Wordpress theme (after getting everything up and running) and I am getting the error:

Are you sure you want to do this?

Please try again.

Now I have looked all over here for the answer but I am importing the correct .zip file so I am not sure what to do.

It's called the 'Enfold' theme.

3 Answers


This error is normally due to an invalid nonce (a token used by WordPress to authenticate the request being made against the user that is logged in). If the nonce fails, you'll see this error.

Unfortunately, there's not a simple fix; it's trial and error. The first thing you'd want to do is disable all plugins. Plugins hook in to the core, thus they have the ability to change what is output to the browser (thus, they have the ability to cause issues if something isn't quite right) , so to stop that, we need to disable them all so that we're running as close to stock as possible.

With all plugins disabled, log out, log back in and try to upload the theme. If it works, you can then start enabling plugins one-by-one until you run in to a similar issue. When you see the same issue pop up, you'd now want to see what the last plugin you enabled was and check any error logs you may have in your home directory.

If the above doesn't work, the best thing to do would be to simply download a fresh copy of WordPress, backup your current files and then overwrite the current files with those from the freshly downloaded WordPress ZIP. If you're running an older version of WordPress than is current, now would be a good time to upgrade (otherwise do not perform this step).

@jtittle I tried everything you had suggested (there were no plugins activated so I deleted them anyway), still didn't upload.

Was running the latest version of Wordpress but did a re-install and still failed to upload :/

What else could it be?

  • @jwalexander22

    How is the zip file structured? If it doesn't follow WordPress' standard structure for themes, that could be an issue as well, though normally you'd simply see the upload / extraction fail over seeing the error that you're receiving.

    If the theme file follows the same structure as all others you use and you're positive, try the navigating to the link below and generating a new set of salts for your wp-config.php file.


    Simply copy & paste the ones generated for you over your current, save and re-upload the wp-config.php file. This should kick you out, so you'll need to login once again, though this will make sure the configuration used to generate the nonce is in tact and refreshed.

@jtittle So, I did exactly that and still got the nonce. Thought to myself it must be the theme... I have installed this theme on other sites before (each time you buy a new license) so it's strange this error would happen.

I did however manually install the theme and it worked (yay, finally!). Should I move forward with development or still try to fix why it won't upload? Which do you think is the right choice?

Thanks for all your help by the way!

Have another answer? Share your knowledge.