Wordpress Themes Not Showing Up After FTP (LAMP, Ubuntu, Wordpress, Filezilla SFTP)

January 20, 2016 4.1k views
WordPress LAMP Stack Ubuntu
lhaley
By:
lhaley

Hey all! Thanks for any time you take to help me.

I have a Ubuntu 14.04 server setup, with LAMP installed after following this DigitalOcean tutorial. I then installed Wordpress following this DigialOcean tutorial.

Everything is running smoothly, except when trying to upload themes.
I am using Filezilla's SFTP which as been successfully configured and connected to my server without a problem. I have tried to install three different themes, all with the same result.

When I upload themes via Filezilla SFTP, they successfully upload into my server's "~/wp-content/themes" folder. However, when I try to access them via my WP Admin panel, they simply do not appear.

I am thinking this may be a permissions problem, as the default WP 2014, 2015, and 2016 themes work fine, and can be changed without an issue. That said, my main (non-root) user account should have all permissions necessary.

Does anyone have any advice on how to resolve this issue? Thank you!

3 comments
  • Are you uploading the themes to ~/wp-content/themes or to your web root? Typically ~/ indicates a user's home directory and that is not normally where you would install Wordpress.

  • Thanks for your reply, Andrew!!

    I'm new to the Linux syntax, so I may very well have indicated the incorrect directory. I looked at what appears to be the default directory and it showed up as ~/wordpress/wp-content/themes.
    However, upon further investigation, I also found the same directory under /var/www/html/wp-content/themes. Is it possible I should be uploading the themes to the latter directory rather than the former?

  • Oh man, oh man!

    Thank you very much for your reply, Andrew. You led me to check further, and indeed the issue was I was simply uploading the files to the wrong directory.
    When I went back in with Filezilla, I uploaded the theme to /var/www/html/wp-content/themes instead of ~/wordpress/wp-content/themes and it worked flawlessly!

    It was a simple misunderstanding as to which directory was being sent to the web.
    Thanks again, my problem is solved!

1 Answer

You need to upload to the** /var/www/html/wp-content/themes**

Also, after you have uploaded, check the ownership of the files in /html, if it says www-data when doing ls -al /var/www/html from your ssh terminal, then make sure all the files in the new theme folder you have uploaded are also www-data. This will ensure maximum compatibility with WordPress. You can do this by doing: chown -R www-data:www-data /var/www/html/wp-content/themes/yourthemefoldername

Have another answer? Share your knowledge.