Question

Wordpress unable to upload and install theme

Hi, I used one click install for Wordpress (ubuntu 14.04) I uploaded the theme and it keeps showing “are you sure you want to do this”.

I have another wordpress account and I’ve managed to upload the exact same theme successfully. Already configured my php.ini (for maximum file size) to 32M and gave all the root read write permissions - I’m totally at a lost now. Please help!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @awesomekel:

I solved it. We have to change post_max_size in php.ini. I did everything I could, didn’t work, even killed my droplet and started again… but when I changed it, it worked!

; Maximum allowed size for uploaded files.
upload_max_filesize = 40M

**; Must be greater than or equal to upload_max_filesize
post_max_size = 40M**

View the original comment