Wordpress uploading image hangs

  • Posted February 13, 2013

I’ve just set up LEMP on a new droplet following some tutorials from DO. After that I have set up a wordpress, everything works fine except for image (media) uploading. The upload page just hangs for several minutes and ends up throwing this:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

I’ve tried changing permission to both 755 and even 777 but still not working, any ideas ?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You may want to check max execution time as well and also try uploading a very small image say 1kb just to minimize variables. <br> <br>If a 1kb fails then you know its not a file size limit or execution problem but instead something else.

Thanks @Olaf that crosses my mind too. @kamal hmm I don’t think so because the image is just ~100k.

This probably means that the image you are uploading is larger than PHP’s maximum upload size.

I tried to install nginx for my Wordpress site too, but I went back to a virtual host setup with apache and suphp. This works the best for my on more than 5 servers. I’ve follow the steps from this tutorial: <br>

PS. I’m using Ubuntu 12.04