128.199.54.130 / Active / 512MB Ram / 20GB SSD Disk / Amsterdam 3 / Ubuntu WordPress on 14.04

I’m using Wordpress on a freshly installed droplet - less than a day old - and trying to install a plugin and it leads me to a page that reads:

“You do not have sufficient permissions to access this page.”

Truth is I just deleted / scrubbed my droplet yesterday because of this new issue and that did not help…

I haven’t changed my table prefix in my wp-config.php file…
$tableprefix = ‘wp’;

I found this - but I really don’t know what phpMyAdmin is, and I aslo don’t know where my db is stored…
https://wordpress.org/support/topic/wp-admin-you-do-not-have-sufficient-permissions-to-access-this-page

I would appreciate if you can help me with this. TIA.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

This sounds more like a file permission issue. Make sure the file permission are set properly all files should have a 644 and folders should be 755.

if you need assistance repairing permissions I would look here. They have a script taht set the proper wordpress permissions.

You can use the following script to list all tables of your WordPress database:

<?php
require_once 'wp-config.php';

if ( ! mysql_connect( DB_HOST, DB_USER, DB_PASSWORD ) ) {
    echo 'Could not connect to mysql ' . mysql_error();
    exit;
}

$tables = mysql_list_tables( DB_NAME );
while( $table = mysql_fetch_row( $tables ) ) {
    echo $table[0] . '<br>';
}

Create a file named table.php (or any name) inside the WordPress files folder, paste this code and access it over the browser:

http://128.199.54.130/table.php

It should list all the tables in your WordPress database, make sure all of them are prefixed with wp_.

A few other things I noticed:

Your site URL is set to the IP address, to change this login to WP-Admin > Settings > General, set both WordPress Address (URL) and Site Address (URL) to http://yitzwoolf.com.

The www version of the site does not have a DNS record. In the DNS section of your DigitalOcean control panel, create a CNAME record as follows:

CNAME record

Don’t miss the dot at the end of the second text box.

Since you have not posted anything on WordPress yet, I would suggest giving ServerPilot.io a try. It is a hosted control panel which makes managing your server a lot easier. It installs only on a fresh server.

Submit an Answer