WP Duplicator Restoration

November 18, 2013 2.6k views
Hi, I'm trying to restore a Duplicator package to one new Droplet. Did install the one click WP application on it, after I realized the restoration of the package requires an empty directory only. So my question is, what's the best way to create/configure a droplet to handle a Duplicator restoration? Maybe someone has had the experience and can share. Thanks! Chung
5 Answers
A lot of folks that deploy WordPress via the one-click install seems to have permissions problems. What's the output of:
ls -la /path/to/WordPress/installation

If you see root:root sprinkled anywhere in there, execute:
sudo chown -R www-data:www-data /path/to/WordPress/installation
I believe you can spin up a droplet with a default wordpress installation and then install Duplicator on it and restore your previous settings.

Let me know if that works
Hi Kamal, tried that, but there's no restore option. I tried connecting to FTP using the ip address, but it won't connect using the root. Maybe I'll just follow the other guides, for initial server setup, install LAMP, FTP and try from there? ok, almost 1am here, been sitting almost the entire day now.
Any updates to this, can't get this to work either?
Same here.

Created a standard wordpress droplet,
uploaded the installer.php + (created via WP Duplicator)
but can not execute the installer.php.

Also tried what "Pablo" recommended without success.

Any quick tip to make this work would be highly welcome. I start all wp projects with a blueprint install via the wp duplicator. Without that working I can not use digital ocean for my projects.

If I can help to find the solution or provide any files / info, please let me know.

Thanks a lot,
Have another answer? Share your knowledge.