Hi Guys,

I recently installed WP Super Cache flawlessly, however, today I noticed that I couldn’t update Wordpress and my plugins automatically. Thus, I chown my “public_html” directory again with my username and the apache group.

Now, I can’t seem to access the WP Super Cache settings on the administration panel.

Your cache directory (/var/www/website.com/public_html/wp-content/cache/) or /var/www/website.com/public_html/wp-content need to be writable for this plugin to work. Double-check it.

I can set the cache folder to 777 and the wp-cache-config.php to 666, however, that would be less secure.

Any ideas on how to resolve this?

J.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hey there,

Here is a tutorial that goes over permissions in Linux as an overview.

You can scale the permissions back to a 755/644 if you make the folder and files owned by the web server process. Example:

chown -R apache:apache /var/www/website.com/public_html/wp-content/cache/

Happy coding,

Jon Schwenn
Platform Support Specialist
DigitalOcean

by Justin Ellingwood
In this article, we will discuss how to read and manipulate Linux permissions. We will cover how to use the "umask" command to choose default permission settings, and the "chmod" command, which can change the permissions of files and directories.
Submit an Answer