Question

WPMS database error on install

  • Posted August 2, 2013

I’ve run several WPMS installs in the past, but never run into this.

Environment:

So files are in /var/www/domain.com/public_html and WordPress install goes swimmingly. check the vanilla install and can update plugins, upload media, etc.

Turn on WPMS using: define(‘WP_ALLOW_MULTISITE’, true);

Jump back in and the Tools > Network Setup is there. Recommended config defines are: define(‘MULTISITE’, true); define(‘SUBDOMAIN_INSTALL’, false); define(‘DOMAIN_CURRENT_SITE’, ‘domain.com’); define(‘PATH_CURRENT_SITE’, ‘/’); define(‘SITE_ID_CURRENT_SITE’, 1); define(‘BLOG_ID_CURRENT_SITE’, 1);

and the .htaccess recommendations are also standard. Plug those in… and run bang into “Error establishing a database connection”

So something strange is happening between the standard and the WPMS install: probably something to do with the path because of the virtual host setup. I notice that these instructions are only for running in the root (with IP address as DOMAIN_CURRENT_SITE) but I’ve run WPMS in similar virtual host environments before without issues.

https://www.digitalocean.com/community/articles/how-to-set-up-multiple-wordpress-sites-using-multisite

Help appreciated!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Here’s some info. from the <a href=“http://codex.wordpress.org/Multisite_Network_Administration”>WordPress Codex</a>:<br/><h2>Apache Virtual Hosts and Mod Rewrite</h2>To [allow] <strong>mod_rewrite</strong> to work within an Apache Virtual host [make sure you enable it, first; and] you may need to set some options on the DocumentRoot.<br/><br/><code><VirtualHost *:80><br/> DocumentRoot /var/www/vhosts/wordpress<br/> <Directory /var/www/vhosts/wordpress><br/>  AllowOverride Fileinfo Options<br/></Directory></code><br/><br/>In some instances, you will need to add <strong>All</strong> to your <strong>AllowOverride</strong> for all .htaccess rules to be honored.

I have a hunch that the way you’re structuring your directories what’s causing you problems… lemme look into it some more.

Add these in: <br> <br>define(‘WP_DEBUG’, true); <br>define(‘WP_DEBUG_LOG’, true); <br>define(‘WP_DEBUG_DISPLAY’, true); <br>define(‘SAVEQUERIES’, true); <br> <br>Reload the wordpress site, do you see any errors?