I have a Centos VPS. Even when I’m kind of new configuring Linux, it’s known to me that I have to unable root access for security purposes. But then what can I do If I have to enter root again?

Once I tried to access the Console through VNC from DigitalOcean page. My trouble is that I couldn’t type many symbols like “/”, thing that prevents me from navigating through folders.

I tried creating an admin user, but I’m not very sure if I did well, since I couldn’t access all files.

My questions are:

  • How can I type symbols like “/” in the VNC Console?
  • Should I rely only on the new admin user?
  • Opening root should be a necessity in the future?

PD: I’m not sure if it has something to do with my laptop keyboard, but my configuration is Spanish ISO.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

By default all droplets are configured for an en-US keyboard layout. You can adjust this using the method outlined here.

In general we recommend administering your droplets via ssh and utilizing the console in the control panel as a method for emergency access should your droplet encounter a problem that causes you to lose ssh access.

  • Thanks @ryanpq , but I had no success. First, I found empty /etc/sysconfig/keyboard, then I added KEYTABLE=”es” LAYOUT=”es-mac”. Finally I shutdown. Nothing happened, in VPN I still can not type characters like the following: - :

    I’m using Centos 7, so I followed this other tutorial: link, It says I have to execute localectl set-keymap es. Nothing happened.

Submit an Answer