Question

www CNAME problem in DNS section

  • Posted February 13, 2015

I have a domain from Godaddy.com , name is cihankoseoglu.com

I set up a ghost blog, and because i have custom domain gmail service on the domain i changed the nameservers to digital ocean and then added the MX records. the A record points to the IP address and everything seems fine.

Except that it isn’t. I can reach the website when I type *cihankoseoglu.com * but when I type www.cihankoseoglu.com i can’t reach the website. I tried messing with the CNAME record but to no avail.

I tried the solution in the following link, did not work. https://www.digitalocean.com/community/questions/i-want-both-www-and-the-root-domain-to-point-at-my-ghost-blog-how-do-i-do-this

Thanks for the help

Subscribe
Share

I have the same issue and have waited 8+ hours for propagation to no success:

[works] A and AAA records for @ [fails with site cannot be reached] CNAME www @

Edit: I just realised ‘propagation’ doesn’t occur and I need to instead wait for cached records to expire - I may have incorrectly configured my previous CNAME and then after fixing it now I need to wait for the 12 hour cache it was set at to expire.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Similar issue here. If I create 2 CNAMEs pointing at my droplet:

If you have an A record for @ pointed to your IP address you should just need to add the following CNAME record:

CNAME www @

Interestingly, I encountered the same problem, also with a ghost-based blog. I’ll just wait some time and see…

After couple of hours this is now woking. So it seems like, after properly configuring the options, all you have to do is to wait for a while.

I have the same problem. I can access my domain via “domain.com” but not via “www.domain.com” My set up is identical to what’s in the https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean

CNAME is pointing to @ and @ is pointing to my droplet. Perhaps I should give it some time.

dns recods images