Question

www.example.com' not working but 'example.com' works along with all https redirection

Running website great along with SSL in all ways but when i try to access www.example.com, it gives Bad Request (400) error.

I need to open website in all ways either we type www or without www- needs to open always in https

I am using ubuntu 20.04 with cake PHP application

Whats going on ? can anybody find a solution?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @kisteneducation

Are you using LEMP or LAMP stack? You can follow @bobbyiliev suggestion and check the Apache error_log and for Nginx you can also check the error_log using this command:

  1. sudo tail -100 /var/log/nginx/error.log

You can share the Apache/Nginx config files too.

Regards, Alex

Hi there,

What I could suggest is checking your Apache error log to see if you would get some more information there:

sudo tail -100 /var/log/apache2/error.log

Also, could you share your Apache Vhost configuration here?

Regards, Bobby