Hi, I hope someone can help with with this.
I have setup my website on the droplet (wordpress) and it all loads fine and is secured. The normal load is https://mydomain however, when I put a www. in front of it, it goes to a 404.
I have A records setup for both blank to IP address and www. to the IP address. Any help would be greatly appreciated.
Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi there @hostingWhale,

What I could suggest is changing the DNS record for your www from an A record to a CNAME record and pointing it to your main domain name.

Another thing that you could do is to check your Apache virtual host at:

cat /etc/apache2/sites-enabled/yourdomain.com

There you need to add your www version as a ServerAlias.

Regards,
Bobby