Question

www subdomain not working

Posted September 26, 2016 3k views
ApacheDjangoUbuntu 16.04

I know this has been asked many times and there a lot of questions and answers regarding this. I’ve tried all of them but none of them worked for me. I will put here important details regarding my setup

sites-available folder

  • 000-default.conf
  • blogs.ai-labs.conf
  • 000-default.conf.save
  • default-ssl.conf
  • ai-labs.co.conf
  • f5exam.ai-labs.conf
  • api.ai-labs.conf

sites-enabled folder

  • ai-labs.co.conf
  • api.ai-labs.conf
  • blogs.ai-labs.conf
  • f5exam.ai-labs.conf

ai-labs.co.conf file

    <VirtualHost *:80>
            # The ServerName directive sets the request scheme, hostname and port that
            # the server uses to identify itself. This is used when creating
            # redirection URLs. In the context of virtual hosts, the ServerName
            # specifies what hostname must appear in the request's Host: header to
            # match this virtual host. For the default virtual host (this file) this
            # value is not decisive as it is used as a last resort host regardless.
            # However, you must set it for any further virtual host explicitly.
            ServerName ai-labs.co

            ServerAlias www.ai-labs.co
            ServerAdmin admin@ai-labs.co
            DocumentRoot /var/www/html/ai-labs.co/

            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn

            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined

            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf

            # <Directory /var/www/html/web-api-example>
            # <Directory /var/www/html/music-store>
            <Directory /var/www/html/ai-labs.co>
                    Options Indexes FollowSymLinks
                    AllowOverride All
                    Require all granted
            </Directory>

            #Alias /static /var/www/html/web-api-example/static
            #Alias /static /var/www/html/music-store/static
            # <Directory /var/www/html/web-api-example/static>
            Alias /static /var/www/html/ai-labs.co/static
            <Directory /var/www/html/ai-labs.co/static>
                    Require all granted
            </Directory>

             <Directory /var/www/html/ai-labs.co/static>
                    Require all granted
            </Directory>

            Alias /static /var/www/html/ai-labs.co/media
            <Directory /var/www/html/ai-labs.co/media>
                    Require all granted
            </Directory>

            # <Directory /var/www/html/web-api-example/student_list_system>
            <Directory /var/www/html/ai-labs.co/ai_labs_website>
                    <Files wsgi.py>
                            Require all granted
                    </Files>
            </Directory>

            # WSGIScriptAlias / /var/www/html/web-api-example/student_list_system/wsgi.py
            # WSGIScriptAlias / /var/www/html/music-store/music_store/wsgi.py
            WSGIScriptAlias / /var/www/html/ai-labs.co/ai_labs_website/wsgi.py

    </VirtualHost>

I already did the CNAME where www is the name and @ is my hostname.

I really don’t get it why the www subdomain just won’t work

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

There is a great tutorial for redirecting www to non-www on DigitalOcean right here: How To Redirect www to Non-www with Apache on Ubuntu 14.04

Give that a shot an get back to me :)

by Mitchell Anicas
This tutorial will show you how to redirect a www URL to non-www, e.g. `www.example.com` to `example.com`, with Apache on Ubuntu 14.04. We will also show you how to redirect in the other direction, from a non-www URL to www.
Submit an Answer