WWW Website redirects to NOT Secure IP (while HTTPS works correctly)

Posted March 18, 2020 907 views
ApacheLet's Encrypt

I’ve installed Wordpress on Ubuntu Droplet, migrate my website and then add the Let’s Encrypt cert. If you browse the website using HTTPS everything works but when you access the website with www it redirects to the IP with a Warning of NOT Secure Website.

If then you click on Continue to the website it goes to the secure HTTPS.

I’ve installed Really Simple SSL plugin on Wordpress but still the same issue.

Any idea how to fix this?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Hi @liukrossini,

This sounds being an issue with your Apache Vhost file. You’ll need to review it and make sure everything is actually configured properly.

If you are uncertain how to proceed in checking your Vhost file, I’ll recommend going over the following two tutorials :

They should guide you through the process of creating a virtual host and you would be able to see the differences with yours. If you however still experience issues afterwards, you can post your vhost files here.


by Lisa Tagliaferri
This tutorial will guide you through setting up multiple domains and websites using Apache virtual hosts on an Ubuntu 18.04 server. During this process, you’ll learn how to serve different content to different visitors depending on which domains they are requesting.


So I’ve followed the step by step guide for the Vhost but I still get the same error.

I managed to add the correct vhost configuration, then I tried to reinstall the SSL certificate but when I tried to redirect all the traffic to HTTPS I got an error

Even when I tried to do the Auto-Renewal test I got another error.

I really don’t understand the issue here.. any help??

  • Hey, I’m experiencing the same thing. When I type in my domain name it goes to my IP address, tells me the certificate doesn’t match. When I use https, it works.

    Did you solve it?