You don't have permission to access /awstats/ on this server.

Posted November 20, 2018 23.6k views


I’m trying to get Awstats to work with my LAMP stack. I followed a guide to configure it(Awstats Guide)

After configuring it I’m getting a “You don’t have permission to access /awstats/ on this server.”

So after a lot reading I ended up with this in the /etc/httpd/conf.d/awstats.conf:

Alias /awstatsclasses "/usr/share/awstats/wwwroot/classes/"
Alias /awstatscss "/usr/share/awstats/wwwroot/css/"
Alias /awstatsicons "/usr/share/awstats/wwwroot/icon/"
ScriptAlias /awstats/ "/usr/share/awstats/wwwroot/cgi-bin/"

<Directory "/usr/share/awstats/wwwroot">
Options FollowSymLinks
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all

I also created the /etc/awstats/ for a virtualhost, changing the LogFile directory, SiteDomain, HostsAliases and AllowToUpdateStatsFromBrowser options.

I’ve tried a lot of fixes but none of them worked .I think it’s a problem with being able to execute cgi scripts.


These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

The <Directory “/usr/share/awstats/wwwroot”> was wrong, changed to <Directory “/usr/share/awstats/wwwroot/cgi-bin”> and I can now access it from the web.

Icons are missing tho.