Question

You don't have permission to access / on this server. Wordpress multiple sites Ubuntu

Dear SD i have made a droplet with wordpress. We have decided to add another wordpress. So i created 2 folders in /var/www , firstsite & secondsite. ( i renamed the real site names to firstsite & secondsite just for this forum

drwxr-xr-x  5 www-data www-pub 4096 Apr 11 15:26 firstsite
drwxr-sr-x  5 www-data www-pub 4096 Apr 11 16:47 secondsite

Al files in the folders have sufficient R&W permissions

i followed the instructions in https://www.digitalocean.com/community/tutorials/how-to-set-up-multiple-wordpress-sites-on-a-single-ubuntu-vps

but now i am getting the error You don’t have permission to access / on this server

I tried creating a .htaccess since it was not working containg this:

DirectoryIndex index.html index.htm default.htm index.php index.php3 index.phtml index.php5 index.shtml mwindex.phtml

but that didnt work this is my apache2.conf file

ServerRoot "/etc/apache2"
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel crit
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf


<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>


AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>
.
.
.



#<DirectoryMatch ^.*/wp-admin/>
#  AuthType Basic
#  AuthName "Restricted Area"
#  AuthUserFile /etc/apache2/.htpasswd
#  Require valid-user
#</DirectoryMatch>
<VirtualHost *:80>
   ServerAdmin webmaster@firstsite.nl
   DocumentRoot /var/www/firstsite
   Servername firstsite.nl
   ServerAlias www.firstsite.nl
 </VirtualHost>

<VirtualHost *:80>
   ServerAdmin webmaster@secondsite.nl
   DocumentRoot /var/www/secondsite
   Servername secondsite.nl
   ServerAlias www.secondsite.nl
 </VirtualHost>

this is my firstsite.conf file

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/firstsite
        ServerName firstsite.nl
        ServerAlias www.firstsite.nl

        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
        <Directory /var/www/firstsite>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

Hope you can help me out

btw i also see nothing in my error.log

[Sun Apr 12 06:35:47.361685 2015] [mpm_prefork:notice] [pid 31786] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.7 configured -- resuming normal operations
[Sun Apr 12 06:35:47.361750 2015] [core:notice] [pid 31786] AH00094: Command line: '/usr/sbin/apache2'

Hope someone can help me thanks in advance


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Solved i had the default.conf file still enabled