Hi Everyone, i am facing an issue while importing my database via the SSH, when i import the database i get this error .

ERROR 1064 (42000) at line 31734: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near “C:24:"WPSEOSitemapCache_Data”:152414:{a:2:{s:6:“status”;s:2:“ok”;s:3:“xml”;s:’ at line 2

I have no idea why this is happening, plus my database size is also huge and its 1 GB. Please help me out my site is down from days.

I was using vestaCP and exported the .sql file via the Phpmyadmin and now i reinstalled my server and vestaCP and now i cant import please help me out.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

The most common reason for this type of error is if the line reported includes a special character or in some other way breaks the MySQL syntax. Your best option is to review this line manually in a text editor and make adjustments to comment out special characters that may be causing the issue.

There are options that can be selected in PHPMyAdmin or mysqldump that will help resolve this type of issue in the export but without access to the original server this is the best option.

Submit an Answer