Question

your settings.py is set to True, (but it is not! it clearly reads: Debug = False)

I have my django installed properly with all the gunicorn, nginx and systemd collaborating with each other, I can see the Congratulations page you have successfully installed django etc. Yet, it says that my debug at settings.py file is set to True, which is not.

Also I have created a hello world page at views.py and urls.py and it says page not found. when I go mywebsite.com/home I am inside my virtualenvironment because it is there where I installed everything, of course.

from django.http import HttpResponse

def home(request): return HttpResponse(‘hello’)

and the urls.py

from django.contrib import admin from django.urls import path from myapp import views

urlpatterns = [ path(‘admin/’, admin.site.urls), path(‘home/’,views.home, name=‘home’), ]

Subscribe
Share

i know about that and tested it under 4 different browsers, browsers that had never been to the site. no change. Besides, even if I had been using a browser locked on its cache, that would not impede accessing a newly created page like /home

Clean browser cache


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I found the answer on Stackoverflow

https://stackoverflow.com/questions/38617046/django-debug-false-still-runs-in-debug-mode/51153638

As a note for others: I had the same problem; I configured my production website on a VM with gunicorn and nginx, following the tutorial for ubuntu 16.04 from the digital ocean documentation.

I wasn’t able to turn off the debug mode, even when restarting the nginx systemd’s service: the solution was to restart also the gunicorn service:

systemctl restart nginx gunicorn