Question

zPanel Cron Not Working? Can not add cron or task not being executed

  • Posted on November 29, 2014
  • alexusAsked by alexus

Hi we have zPanel 10.1 Im trying to add cron but its not working, im getting script does not exist error or when path is accepted our script file is not actual executed :(

here is what i tried:

php -q  /var/zpanel/hostdata/<*account*>/public_html/<*domain*>/api/cron/index.php

or

php -q  /<*domain*>/api/cron/index.php

says script does not exist

I can add something like this:

/<*domain*>/api/cron/index.php

but file is not being executed :(

Crontab is running, process is up and i see zPanels internal things are being executed just fine.

tnx for help!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, all

I have not personally used zPanel, but to me, this project looks completely abandoned. There have been no updates to that repository for the past 7 years:

https://github.com/zpanel/installers

The last installer script which was supported was for Ubuntu 12, which has been EOF for a very long time:

https://github.com/zpanel/installers/tree/master/install

I would recommend choosing a different control panel. You could start by having a look at this page here for some useful Control panel tutorials:

https://www.digitalocean.com/community/tags/control-panels

There are a lot of web panels available (most of them are free to use) that you can choose in order to manage your server. What I can recommend is to try them as in this way you can see if it really suits your needs.

I will list the top control panels that I recommend:

CentOS Web Panel Vesta CP Webmin Ajenti ISPConfig

and of course I need to mention Plesk although it’s not free it’s been available for a while and it’s always been the main cPanel competitor. It has a lot of build-in features and a lot of plugins that you can install and you can always reach to their support team if needed which is something that might come in handy in time.

You’ve now got some great options if you want to use a control panel with your server but you don’t want to pay for a license. I’ve tried to layout most of the available options, but which one is best will ultimately depend on your individual needs.

Regards, Alex

i used wget as work around. later on in the log i found that “index.php” i was referring to was executing differently when requested from Cron rather then a browser. So i think if i make it look at different includes it would work. PHP error was found in apache error logs for that domain

Any luck on getting this resolved?