Question

Akauting PHP Error

Hi!

I’m trying to update the Akauting software. I’ve just run the upgrade command in my Ubuntu 18.04.

However, the following errors don’t allow the complete Akatung update:

“You can not upgrade to Akaunting 2.1 version because your PHP version is lower than 7.3.0. Please, ask your hosting company to upgrade your PHP.”

and:

“The PHP CLI executable file is not working! Please, ask your hosting company to set PHP_BINARY or PHP_PATH environment variable correctly.”

How can I fix that? Thank you so much!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thank you

Hi there,

As far as I can tell for the error that you are getting, you have to upgrade your PHP version. To do that you could follow the steps from this answer here:

https://www.digitalocean.com/community/questions/how-to-upgrade-php-7-0-33-to-7-4-7-on-ubuntu-16-04-nginx

Hope that this helps. Regards, Bobby