All E-mails directed to Hotmail from any mail account get rejected

March 20, 2015 2.6k views
Messaging Email Security DNS Apache Ubuntu

Hey guys,

I'm having a VPS running on Ubuntu 14.04, IP: and for some reason any E-mail that is sent to a hotmail account (tested with both an existing as a just newly created one) is not being received. Any other E-mail account (i.e. Gmail) has no problem.

As far as I would say everything is set up fine, but we can simply say apparently it is not.

My VPS FQDN is which is my main (business) domain. But on that same server, other clients of mine are hosted. One of those (Testing with this one and my business domain) is

I've set up dynamic DNS (as much as possible, excluding PTR), so that the mail DNS gets mail.<domain>.<tld>. Or in exact cases, or However of course: The main domain of the VPS remains as this cannot be set up dynamic.

Sending a test E-mail and posting the log of that E-mail /etc/log/mail.log below

Mar 20 15:05:06 iscs postfix/smtpd[1786]: connect from localhost[]
Mar 20 15:05:06 iscs postfix/smtpd[1786]: BDF67120D70: client=localhost[], sasl_method=LOGIN,
Mar 20 15:05:06 iscs postfix/cleanup[1790]: BDF67120D70: message-id=<>
Mar 20 15:05:06 iscs postfix/qmgr[1038]: BDF67120D70: from=<>, size=1015, nrcpt=1 (queue active)
Mar 20 15:05:06 iscs postfix/smtpd[1786]: disconnect from localhost[]
Mar 20 15:05:08 iscs postfix/smtp[1791]: BDF67120D70: to=<>,[]:25, delay=1.3, delays=0.04/0.02/0.45/0.82, dsn=2.0.0, status=sent (250  <> Queued mail for delivery)
Mar 20 15:05:08 iscs postfix/qmgr[1038]: BDF67120D70: removed

I'm seeing ":25" on that line. I'm pretty sure I'm using port 587 instead of 25 for sending E-mails, because of an somehow unsolvable error.. Couldn't be the issue, right? Since It sends to Gmail correctly.

Besides seeing a lot of 'relay access denied' in the log itself (elsewhere) I really haven't got a clue what could be the issue.

Hopefully this issue could be solved soon, since I'm launching there website soon (promised today..), but there are a few contact forms that should be working. So while Hotmail accounts aren't 'accessible', the site cannot be launched..

Any help is appreciated much!

I'm offering a donation for answer solving this issue.

  • What are you doing with this supposed dynamic DNS? There shouldn't be more than one record that refers to your mail server.

    Also, according to this log, the mail is being queued to Hotmail fine. So I don't know why you're ignoring the relay access denied messages - they seem like the most relevant lines out of everything so far. You may receiving mail failure notifications from hotmail or you could check your spam folders as well.

  • Perhaps I need to clarify the dynamic DNS. I'm using a DNS template for all my domains. Every place where a domain is filled in, such as the mail record, it's dynamic. I'm not using the DNS service by DigitalOcean, by the way.

    On the template, there is written: "mail.|DOMAIN|" which results for my domain "" and automatically for '' to "". That way every domain uses it's own mail "server" and 'personal' records.

    I hope you understand what I mean.

    But referring to the hotmail problem. I've tested it, as written, with multiple Hotmail accounts and none of them receive my E-mail. Neither in there inbox, neither in their junk box. Sure, It's getting sent from my side of the internet fine, but it's probably rejected by Hotmail, somewhere.

    I'm not ignoring the 'relay access denied' messages, but I've set up multiple topics in the past month over at StackExchange and spent many, many hours on Google and testing but nothing solved the issue. Therefor I'm requesting additional help- and note that in my post.

    Thanks in advance.

  • You may want to contact Hotmail? If they're the one you're having trouble with, they should probably be the ones to contact.

    Also, after reading your explanation of the DNS thing - you shouldn't do that, there's literally no reason to and it will cause problems more than anything. If you do it for automation, simply stick to one record.

  • I've contacted Hotmail (Microsoft) but they can't help me. Or.. won't.

    I've (tried to) set up DKIM for the specific domain ( and awaiting DNS changes.
    I've also sent a test mail to Port25Test thing.. And this is the result.

    Anything you find that could cause the problem?

    Summary of Results
    SPF check:          pass
    DomainKeys check:   neutral
    DKIM check:         neutral
    Sender-ID check:    pass
    SpamAssassin check: ham
    HELO hostname:
    Source IP:
    SPF check details:
    Result:         pass 
    ID(s) verified:
    DNS record(s): SPF (no records) 14400 IN TXT "v=spf1 a mx ip4: ~all" 14400 IN A
    DomainKeys check details:
    Result:         neutral (message not signed)
    ID(s) verified:
    DNS record(s):
    DKIM check details:
    Result:         neutral (message not signed)
    ID(s) verified: 
    NOTE: DKIM checking has been performed based on the latest DKIM specs
    (RFC 4871 or draft-ietf-dkim-base-10) and verification may fail for
    older versions.  If you are using Port25's PowerMTA, you need to use
    version 3.2r11 or later to get a compatible version of DKIM.
    Sender-ID check details:
    Result:         pass 
    ID(s) verified:
    DNS record(s): SPF (no records) 14400 IN TXT "v=spf1 a mx ip4: ~all" 14400 IN A
    SpamAssassin check details:
    SpamAssassin v3.4.0 (2014-02-07)
    Result:         ham  (2.3 points, 5.0 required)
     pts rule name              description
    ---- ---------------------- --------------------------------------------------
    -0.0 SPF_PASS               SPF: sender matches SPF record
     1.2 RCVD_NUMERIC_HELO      Received: contains an IP address used for HELO
     0.0 HTML_MESSAGE           BODY: HTML included in message
    -0.5 BAYES_05               BODY: Bayes spam probability is 1 to 5%
                                [score: 0.0477]
     1.7 FSL_HELO_BARE_IP_2     No description available.
3 Answers

Hi have the exact same problem. I'm able to send email to all servers except hotmail. The mail logs tell me that the email is properly sent:

Jul 17 11:51:14 woloweb postfix/submission/smtpd[1620]: connect from[]
Jul 17 11:51:17 woloweb postfix/submission/smtpd[1620]: 6B1DB60D62:[], saslmethod=PLAIN,
Jul 17 11:51:17 woloweb postfix/cleanup[1622]: 6B1DB60D62:
Jul 17 11:51:17 woloweb opendkim[667]: 6B1DB60D62: DKIM-Signature field added (s=mail,
Jul 17 11:51:17 woloweb postfix/qmgr[1276]: 6B1DB60D62:, size=598, nrcpt=1 (queue active)
Jul 17 11:51:18 woloweb postfix/submission/smtpd[1625]: connect from[]
Jul 17 11:51:19 woloweb postfix/smtp[1624]: 6B1DB60D62: to=<>,[]:25, delay=1.8, delays=0.36/0.01/0.49/0.98, dsn=2.0.0, status=sent (250 Queued mail for delivery)
Jul 17 11:51:19 woloweb postfix/qmgr[1276]: 6B1DB60D62: removed

But the email never reaches the user. I have properly set the SPF and OpenDKIM records, and everything seems to be fine. I think you should really address this issue.

Hey Arnasio,

I didn't took the effort and patience to set all the records. Especially since I should set the SPF and OPENDKIM records for EVERY domain I've got (right..?). I moved my inbox to ZoHo, a mail inbox provider; 5GB per mailbox and great spam protection, IMAP support, etc. Just create a new account for every domain, which is much less of a hassle.

For sending domains however, I moved my SMTP services to Mandrill (From MailChimp). It reports weekly how many mails have been sent and how many mails have failed. Been using it for over a few months now and none of my mails have been lost in space or even ended up in the SPAM box. For this, all you need to set your SMTP server to in your mail client and you're done. :)

So my advice: Quit an own mail server and move your business to professional, free services :) Much better now! :)

Have another answer? Share your knowledge.