Bukkit Minecraft server spontaneously quits when rendering dynmap

  • Posted October 21, 2013

Hello all,

I am wanting to set up and run a CraftBukkit-based Minecraft server on a droplet. I have installed Java, set up FTP access to transfer in my existing files, and have gotten the server to actually run, so things are going pretty well - but I have hit a snag.

The problem seems to be coming from the dynmap plugin. To save time in transferring the server files, I installed dynmap afresh, and I now want it to fully render the map tile images for the server’s world. However, when I activate the render process, it will run for about 10-20 seconds and then the Minecraft server terminates with no error message.

I have tried this on a 2GB droplet (using 1.5GB RAM for the Bukkit server) and then later on a 4GB droplet (using 3GB for Bukkit). Both times I hit the same problem, although it did take longer for the server to “crash” when trying it on the 4GB droplet.

Am I perhaps hitting some limit with regard to CPU usage, which is in turn automatically killing the Bukkit server process?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It’s probably running out of memory. Try adding swap or upgrading your droplet: <a href=“”></a>. <br> <br>Also try replacing <code>-Xms1024M</code> with <code>-Xms512M</code>.

It’s like the process is getting killed by some kind of manager to detect too-high cpu usage?? I have the same problem. <br> <br>Process started t = 2014-02-16 16:17:39 <br> <br>~ 16:20:13 (t + 4mins) --> <br> <br>>./ line 11: 1492 Killed java -Xmx1024M -Xms1024M -jar craftbukkit-1.7.2-R0.3.jar -o true <br>

I had the same problem a while back that I solved using more memory and 64bit java. <br>Last time I did a full render I used 5gb for bukkit and I had no crashes. <br> <br>I start my server with following command, hope it helps: <br>screen -A -m -S “mc” java -d64 -Xms100M -Xmx5000M -jar -server -XX:+UseConcMarkSweepGC -XX:+DisableExplicitGC -XX:+UseAdaptiveGCBoundary -XX:MaxGCPauseMillis=500 -XX:-UseGCOverheadLimit -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:SurvivorRatio=16 -XX:UseSSE=3 -XX:+AggressiveOpts craftbukkit-1.6.4-R.0.1.jar nogui

Yes, I did check the log to make sure no error message was being caught there, and there’s nothing useful. The last line is from dynmap as it starts the render process: <br> <br>[code]2013-10-21 08:34:14 [INFO] Full render starting on world ‘avalon’…[/code] <br> <br>If I choose to not start a render the server will run indefinitely without problems.

Is there anything in the error logs? <pre>tail -20 /path/to/minecraft.log</pre>