Question

Cachet loads to empty page

I tried installing Cachet yesterday, but I can’t manage to get it installed. I’ve gotten to the point where I can’t go further without help. I’ve experienced 502 errors, SSL errors, basically everything. Now it just loads to a empty page. I get an error in my nginx log.

PHP message: PHP Fatal error:  Uncaught ErrorException: count(): Parameter must be an array or an object that implements Countable in /home/cachet/www/vendor/graham-campbell/exceptions/src/ExceptionIdentifier.php:51
Stack trace:
#0 [internal function]: Illuminate\Foundation\Bootstrap\HandleExceptions->handleError(2, 'count(): Parame...', '/home/cachet/ww...', 51, Array)
#1 /home/cachet/www/vendor/graham-campbell/exceptions/src/ExceptionIdentifier.php(51): count(NULL)
#2 /home/cachet/www/vendor/graham-campbell/exceptions/src/ExceptionHandlerTrait.php(47): GrahamCampbell\Exceptions\ExceptionIdentifier->identify(Object(Symfony\Component\Debug\Exception\FatalErrorException))
#3 /home/cachet/www/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/HandleExceptions.php(79): GrahamCampbell\Exceptions\ExceptionHandler->report(Object(Symfony\Component\Debug\Exception\FatalErrorException))
#4 /home/cachet/www/vendor/laravel/framework/src/Illu

I just can’t get further. I tried following several tutorials, but none of them used php7.2, so maybe that’s the issue? I don’t really know.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It appears that this is a known issue for Cachet with PHP 7.2. It is recommended to use a newer dev version of Cachet if you must use PHP 7.2 currently.

You can find more details here.

Yeah, I figured that out about 2 days ago. Thanks anyways!