Question

Can not join Unturned game server (stuck on loading, "server lost your connection". Not allowing inbound connections?

512 MB Memory / 20 GB Disk / AMS2 - Ubuntu 16.04.1 x64 I have set up a Unturned gameserver which runs at ports 27015, 27016, 27017. The server loads succesfully without any errors. When I try to join the server, I can see in the debug menu that the server didn’t respond in X seconds, it then disconnects me after a 30 second timer.

I have used this tool: http://www.yougetsignal.com/tools/open-ports/ to check if my ports are open, they are not. Even though another post confirmed that all ports are opened by default as soon as a service is listening on them. Just in case I allowed the ports on Uncomplicated FireWall (UFW) both UCP and UDP.

I have been trying a lot of things to no avail. Any help would be greatly appreciated

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

From setting of network interface

# Control-alias eth0
Iface eth0 inet static
     Address 10.15.0.6
     Netmask 255.255.0.0

Please try comment out the local IP address setting like.

In the case of Ubuntu 16.04, this solves the problem. The problem is that the listening IP address was an IP address for DigitalOcean Floating IP.

Machine translation may make reading difficult. Excuse me.

I’ve had the same problem, but I haven’t found a solution.