Can ping public but not private ip between Droplets

I have 2 droplets, one NodeJS and one MongoDB. I can SSH into both of them and run “ping <other-droplet-public-ip>” and get a response, but when I try to ping the private VPC ip of either - it doesn’t work (Destination Host Unreachable).

I have enabled “Private Network” on both droplets, and I have rebooted both as well. Still doesn’t work.

Am I missing something?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have the same problem. Also the the auto ip of the droplets in the OS had another ip. It is not just ping but all the traffic. The droplets cannot communicate.

Hi, I solved it. I do not know why but my droplets had and strange network device called eth0.1. I disabled that device and created eth1, and put there the configs of the Private Network and now everything is working.