Johners
By:
Johners

Can't access WordPress Admin Login With HTTPS Enabled

December 2, 2014 5.2k views

Greetings!

I deployed the WordPress One Click Image. I installed my SSL Certificate and enabled SSL Within Apache2. I also have a rewrite rule to change HTTP to HTTPS and I set my site URL to https within the admin control panel.

However, after doing all of that I am unable to access any of my WordPress Content and I can get to the homepage if I turn off the HTTPS redirect but I'm still unable to get to the admin control panel if I do that.

What can I do regain access to my HTTPS control panel?

4 comments
  • What method did you use when adding your ssl certificate? It sounds like the SSL virtualhost may be pointed to a different location from the non-SSL one. Since you have updated your Wordpress configuration to use https when you disable the redirect you are able to get to the homepage but clicking through to anything else would take you through https links generated by Wordpress.

  • The SSL Certificate is from Namecheap, PositiveSSL and it is Apache2 + MOD SSL (so there is the .crt, .ca-bundle and .key file).

    When looking at the configuration files in apache in /sites-enabled/, the data directy on both is /var/www, the same location in both 000-default.conf and default-ssl.conf.

  • I've done some further searching and port 80 is open while port 443 is closed on my the IP for my VPS. Would that stop HTTPS from working?

  • https runs on port 443 while http is on port 80 by default. With port 443 closed you will definitely not be able to reach your site via https.

1 Answer

This question was answered by @ryanpq:

https runs on port 443 while http is on port 80 by default. With port 443 closed you will definitely not be able to reach your site via https.

View the original comment

Have another answer? Share your knowledge.