Can`t rebuild httpd.conf and start Apache with cPanel [SOLVED]

Posted August 16, 2014 22.4k views

The problem is solved with build of EasyApache with this command:

/scripts/easyapache –build

I have truble with start my Apache service on my droplet. I installed cPanel and FTP & WHM working fine, while the httpd service is down. I look around for information and tried to rebuild the httpd.conf file, but with no success. When I try, get this error:

Rebuilding configuration without any local modifications.

info [rebuildhttpdconf] Missing IP for domain, using
info [rebuildhttpdconf] Missing ServerName for domain, using
info [rebuildhttpdconf] Missing port for domain, using 80
info [rebuildhttpdconf] Missing user for domain, using nobody
info [rebuildhttpdconf] Missing owner for domain, force lookup to root
info [rebuildhttpdconf] Missing group for domain, using nobody
Failed to generate a syntactically correct Apache configuration.
Bad configuration file located at /usr/local/apache/conf/
Configuration problem detected on line 33 of file /usr/local/apache/conf/      : Cannot load /usr/local/apache/modules/ into server: /usr/local/apache/modules/ cannot open shared object file: No such file or directory

        --- /usr/local/apache/conf/ ---
        28Include "/usr/local/apache/conf/includes/pre_main_global.conf"
        29Include "/usr/local/apache/conf/includes/pre_main_2.conf"
        33 ===> LoadModule bwlimited_module modules/ <===
        38Include "/usr/local/apache/conf/php.conf"
        39Include "/usr/local/apache/conf/modsec2.conf"
        --- /usr/local/apache/conf/ ---

edited by etel

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Thanks for posting your solution!