Can't run sshd in debug mode

I have a CentOS 7 droplet. I want to debug sshd. I stop the sshd service. And then do /usr/sbin/sshd -d. I get an error that connection is refused by the tcp wrapper.

Screenshot of sshd console output is here:

I’ve looked at these two articles and googled a bunch but no luck.

I imagine that the problem has something to do with what’s in my /etc/hosts.allow or /etc/hosts.deny. I tried adding an entry into the empty hosts.allow:

sshd: localhost

No luck.

/etc/hosts.deny just has a pile of entries for IPs that have been denied.

I am able to ssh to localhost from the droplet so the problem is more subtle than the machine being blocked from ssh’ing to itself.

Thanks. Sol

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.


Have you tried running SSH on another port as a part of the command?


sudo /usr/sbin/sshd -ddd -p 2200

You don’t have to specifically use 2200, any port that’s open and not in use should work.

The added d’s simply increase the verbosity of the output.