Hiya,

Recently lost the ability to ssh into my FreeBSD droplets. I have two and neither works. I rely on ipfw inside my droplets but to my knowledge have not set up any firewall on the DO side.

I’m sure there’s an easy explanation but I can’t find it.

Thanks for your time.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @davewrobison

You can use telnet or nmap to see if the port is actually open and if you’re able to receive connections on it:

telnet IPADDRESS 22

Using nmap you will see the open ports and the services listening on those ports. If 22/ssh is open you will see it.

nmap IPADDRESS

Also you can use the DigitalOcean’s console in order to access your droplet and see if there is a misconfiguration in the ssh config file. Once you’re logged in you can check if the ssh service is running:

service -e | grep "ssh"
/etc/rc.d/sshd

If nothing is shown after the command, the SSH daemon is not running. Type:

service sshd onestart

to attempt to “kick-start” it.

Hope this helps.

Regards,
Alex

  • Hi,

    This doesn’t help at all. What if you cannot receive from port 22. Since all passwords are internal how do we enable ssh. This happened to me after updating freebsd

    • Hello, juanjoseluisgar

      You can access your droplet using the DigitalOcean console and check if sshd is running using the command I’ve mentioned.

      Additionally you can check if sshd is enabled in the /etc/rc.conf file, the following line should be present in the file:

      sshd_enable="YES"
      

      Let me know how it goes.

      Regards,
      Alex

Submit an Answer