Question

Cannot access WordPress general settings - no data received (Chrome) or server reset (Firefox)

Posted February 28, 2015 4.4k views

I am running Ubuntu 14.04 with Apache and WordPress 4.1.1. In wp-admin I can access all settings except the general settings. When I try to navigate to the general settings I get “no data received” when using Chrome, “server reset” with Firefox or “This page can’t be displayed” with Internet Explorer. How do I go about trouble shooting and fixing this issue.

3 comments
  • you could try disabling your plugins to see if that solves it.

    if so, re-enable them one by one to fine the culprit.

    If plugins are not the problem, try changing themes

  • I disabled all plugins and tried different themes, but that had no effect on the issue.

  • I edited the options-general.php file to find out what could be causing the page not to load. Taking this one line out of the wp_dropdown_languages array allows the page to load:

    'show available_translations' => ( ! is_multisite() || is_super_admin() ) && wp_can_install_language_pack(),
    

    However, I am not savvy enough to understand why the server resets when this line is in the file.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Had the same issue, is linked to adding the secure ssh user i believe in the digitalocean hardening instructions

Patching libssh2-php worked for me

apt-get source libssh2-php
cd php-ssh2-0.12/
wget https://launchpadlibrarian.net/193989033/fix-segfault.patch
apt-get build-dep php-ssh2
apt-get install build-essential fakeroot devscripts
patch -p1 < fix-segfault.patch 
rm fix-segfault.patch 
debchange -i
dpkg-buildpackage -b
debi
Submit an Answer