Cannot install Scipy

Hi, I am currently unable to install Scipy in my virtualenv. I have tried building via pip, wheels (as per the stack overflow suggestion), and the default package manager, but none of them have worked. My error message is as follows:

c++: internal compiler error: Killed (program cc1plus)

error: Command “c++ -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -fPIC -D__STDC_FORMAT_MACROS=1 -I/usr/lib/python2.7/dist-packages/numpy/core/include -I/usr/include/python2.7 -c scipy/sparse/sparsetools/csr_wrap.cxx -o build/temp.linux-x86_64-2.7/scipy/sparse/sparsetools/csr_wrap.o” failed with exit status 4

I have the latest version of gcc as well as all of the scipy dependencies, so I am not sure what is causing this problem.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I had the same problem, and I believe it’s because the scipy install runs out of ram. I followed digitalocean’s guide to adding a swap file and it worked afterwards: <br> <br> <br> <br>I’d make the swap 1024 megs instead of 512 because I got close to running out.

Yup, the article below (travisirby’s answer) worked for me with the suggested 1024 megs of swap.