Configuring WordPress on Ubuntu w/ LEMP - ERROR: There was an error connecting to the server, Please verify the settings are correct.


I have WordPress running on Ubuntu 14.04 with Nginx and I am trying to configure secure updates as per this tutorial

Except I did give the user a password as otherwise I was receiving this error: passwd: Authentication token manipulation error

Nginx error log

Any ideas how to fix it? I am at a complete loss.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @saurabh:

Seems like a file permissions issue. Try setting 755 permissions for the directories under ~/wp-content/

Also, if you have created a FTP user then this user needs to own the directories & files insid, so as to overwrite the files.

PS: It is always better to not to use FTP & “manually” update your WP installation.

View the original comment