Question

Defined wp-config Url to solve redirection now Server unable to handle request

Posted May 2, 2018 1.1k views
NginxPHPWordPressDebianLAMP StackLinux Commands

after changing url in wp admin to https got into indirect loop to solve that i defined wp-config urls and now server error

this is the log files of nginx FastCGI sent in stderr: PHP message: PHP Parse error: syntax error, unexpected :, expecting , or ) in /var/www/html/ wp-config.php on line 20 while reading response header from upstream, client: 172. 68.146.45, server: _, request: GET / HTTP/1.1, upstream: fastcgi://unix:/var/run /php/php7.0-fpm.sock

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

What is on line 20 of wp-config.php?

This error indicates a syntax error which should be easily solvable by viewing the line in question. If you can include a couple lines before and after that would be helpful in case context comes into play in the error.

  • Hi thanks for the reply , that was solved the issue is when i configure cloudflare ssl it went infinite loops after i changed to origin to https and i added the define site name in this line ,
    due to some cache plugins or themes it went another memory error , i disabled all plugins and themes and added a memory set line in wp-setting then it solved

Submit an Answer