Question

Deploying django app singlepoint on domain singlepointfarmer.com getting : Bad Request (400)

Trying to deploy django app singlepoint on singlepointfarmer.com

<VirtualHost 166.62.39.74:80> ServerName singlepointfarmer.com ServerAlias www.singlepointfarmer.com ServerAdmin tcsams@gmail.com Alias /static /var/www/singlepoint/static <Directory /var/www/singlepoint/static> Require all granted </Directory>

    <Directory /var/www/singlepoint/singlepoint>
    <Files wsgi.py>
        Require all granted
    </Files>
</Directory>

WSGIDaemonProcess singlepoint  python-path=/var/www/singlepoint
WSGIProcessGroup  singlepoint
WSGIScriptAlias / /var/www/singlepoint/singlepoint/wsgi.py

</VirtualHost>

Result http://www.singlepointfarmer.com Bad Request (400)

Where is my boo-boo ? Please help - thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I would recommend checking your error logs for some more information. But I believe that the mod_wsgi might be missing. I would recommend following the steps from this tutorial here:

https://www.digitalocean.com/community/tutorials/how-to-serve-django-applications-with-apache-and-mod_wsgi-on-centos-7

Regards, Bobby