Question

DISCOURSE - WARNING: Port 443 of computer does not appear to be accessible using hostname

Connected Tutorial
This question is a follow-up to this tutorial:

I’m doing this to set up Discourse: ./discourse-setup but i am getting the error in the text. How can i fix this error ? I use Ubuntu 18.04 and Webmin

Error: Hostname for your Discourse? [discourse.example.com]: forum.barinaklar.com

Checking your domain name . . . WARNING: Port 443 of computer does not appear to be accessible using hostname: forum.barinaklar.com. WARNING: Connection to http://forum.barinaklar.com (port 80) also fails.

This suggests that forum.barinaklar.com resolves to some IP address that does not reach this machine where you are installing discourse.

The first thing to do is confirm that forum.barinaklar.com resolves to the IP address of this server. You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue. A web search for “open ports YOUR CLOUD SERVICE” might help.

This tool is designed only for the most standard installations. If you cannot resolve the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have the same problem I changed a lot of servers, but the problem remained. Has anyone solved this? Discourse cannot be installed

Hi there @Murtooo,

This usually happens when your domain name’s A record is not pointed to the server IP address.

Have you tried changing your DNS and pointing the domain to the server IP?

Regards, Bobby