Question

Domain Not pointing to the Directory defined in v irtualhost

  • Posted August 18, 2014

Ubuntu 14 , LAMP Even after defining the vitualhost in apche2/sites-available/mydomain.com.conf the domain is still pointing to the var/www/html (which is the default root of server)

The actual directiry defined for mydomain was var/www/mydomain.com/public_html/ but i’m not sure why its not obeying the rule :-( I have setup two more domains, and they worked smoothly.

Subscribe
Share

I fixed it by disabling deafult .cnf file. Yes that catch all suggestion is the bonus ;-)

Thanks U Guys


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I would suggest you to disable the 000-deafult.conf If you want to keep it as a catch all virtualhost for ip / not configured domain which point to the same ip. Just rename it to like ZZZ-CATCH-ALL.conf and add [serverName default] & [serverAlias *]. The name doesn’t matter as long as it is the last in alphabetical order. 000-default.conf may work but making it the last may be better.

I got 500 response from www.ardortech.com and [ARDOR TECH VENTURES will be back soon in a new AVATAR!!] from ardortech.com same as http://ip

Did you use the same ServerName in other site configs or 000-default.conf? Listing /etc/apache2/sites-enabled to is there any other enabled sites.

Could you post your Apache configuration to a pastebin? Without more information, it’s hard to know what’s going on here.

A few quick troubleshooting points… Did you enable the site configuration?

sudo a2ensite mydomain.com.conf

And make sure to restart Apache after any configuration changes:

sudo service apache2 restart