Dovecot says root user does not exist

  • Posted January 4, 2015

I have 5 active mail users in the mail server, each on a separate domain, plus one unused ‘postmaster’ on a 6th domain, in the form of ‘user@dropletname’. where dropletname is domain.tld.

The droplet name was changed prior to installing the server software, which includes Postfix, Dovecot, Mysql, Spamassissin and a self-signed cert.

4 of the active users have email servers working as they should. Each time the email client tries to log in for the 5th user, a “cannot connect permission refused” flag comes up on the client and nothing about the attempt to log in can be found in any of the /var/log/ files on the server. However, there are a few lines saying Dovecot reports no root user.

I have since changed /etc/hostname and the command line now says root@{correct name} but still no connection for my 5th user.

It is certainly a mail server fault, Thunderbird has been tried from 2 machines and Evolution from one of them.

Can anybody point me at the right files to check configuration please? Or how to see if the server has somehow blacklisted or barred this user?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Problem solved but I have no idea why, other than the system taking a while to reconfigure itself with the new name after amending /etc/hostname and rebooting.