Droplet is not powering on

I powered off my droplet because I wanted to create snapshot, when I tried to create snapshot - it said “something went wrong”, after that I tried to start my droplet - BUT IT DOESN’T POWER ON! gif image is spinning already 6 hours! I cannot do anything with my droplet, cannot power it off, cannot power it on, what should I do? how to power on my droplet??

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

No, it started automatically after 28 hours… problem is “solved”